Reading List count correct, but no items showing up

Please see attached, showing both iPhone and iPad. I’m running DTTG v 3.6, on iOS/iPad OS 16.




You didn’t mention doing it, so I’ll suggest first step would be to re-start your iOS device.

I’m seeing that too: one item in reading list on iPhone, but no item to be seen. And I never use the reading list…

Interesting. I don’t see it. I have 614 items in Reading List (yes, I won’t get to all of 'em!), including a few that i added on Mac this morning and DEVONthink and DEVONthink ToGo synced without any intervention by me. Dunno more than that other than a hunch related to the new iOS? The worst type of issue, I guess.

DEVONthink 3.8.6 on macOS 13.0.1 and ios 15.7.1 with DEVONthinkToGo 3.5.7.

OP has different DEVONthink ToGo and iOS than me.

I’m on DTTG 3.6 already. Might be related to that

Do you use iOS 16 focus filters or explicitly don’t? DEVONthink To Go 3.6 filters reading list items in databases currently not visible due to a focus filter.

No, I never use focus filter. At least not that I know of.

Edit: And I just noticed that I do have a reading list on my Mac (which I must have created when fiddling around and then forgot about). Which contains exactly one item. So, on the iPhone, this list is visible, reported to contain one item, but the item itself is not visible.
And: “Fokusstatus” is set to on on my iPhone (I swear that I didn’t set that!). Just turned it off and restarted DTTG, but the “problem” remains.

DEVONthink To Go definitely cannot set any focus status itself. What happens when you set databases for a focus and switch to it? Do items in the selected databases appear? If you try that for us, that would be very helpful. I have a suspicion.

That’s not what I was hinting at :wink: More “Apple knows what is good for me, so they do whatever they see fit when updating my OS”.

How do I do that?

Open Settings > Focus. Choose a focus, like Work. Add DEVONthink as a filter and choose one, two databases as well as minimum one smart group. Now switch back to DEVONthink To Go.

Focuses are a great too, so it might be worth to explore them anyway eventually.

Ok, here’s what I did:

  • selected Work focus
  • selected DT as filter, chose 2 databases and 2 smart groups, one of them the reading list
  • activated the focus in control center
  • switched back to DTTG
  • which now shows only two databases and the two smart groups
  • but the reading list still says “1 item” and showing none.

Now, if I turn the focus off in DTTG, the reading list shows the item.


Is the item located in one of the two databases you chose of the focus?

In any way, point proven already. We’ll look into this early next week.

Nope, it’s in the global inbox. Which I didn’t (and couldn’t) add to the focus filter, IIRC.

I just wanted to report to have similar issue since installing DDT 3.6. No items visible on Reading List even though I see some number next to it.

No “Focus” mode engaged. Databases display as expected, and all of them.

Screenshot above from iPad, but it behaves the same way on iPhone. I even do full re-sync: first deleted DT apps from iPad and iPhone, then I cleaned iCloud sync location, uploaded again from Mac, and then installed and synced iPad and iPhone DT apps again.

Forgot to add: yes, on my Mac there is several dozen items on Reading List, and previously they displayed on mobile devices just fine.

Thanks for these steps. I was able to enable the Reading List smart group the same way - by enabling the Focus filter and then turning it off from within DTTG - the Reading List “stayed on” once I deactivated the Focus Filter. That’s pretty weird and certainly not intuitive

I appear to have a similar problem Global inbox synchronises 0K show 3 items in reading list on my iPhone and iPad but nothing is displayed in the reading list

I’m having the same issue on my iPhone and iPad. The count shows 27 items in my reading list but only 1 item shows up. All documents seem to be present on the devices and no focus filters are active.

I suggest that we stop filling this thread with “me too” posts. According to @eboehnisch, the developers have got the message and are working on the problem.

1 Like